codetoad.com
  ASP Shopping CartForum & BBS
  - all for $20 from CodeToad Plus!
  
  Home || ASP | ASP.Net | C++/C# | DHTML | HTML | Java | Javascript | Perl | VB | XML || CodeToad Plus! || Forums || RAM 
Search Site:
Search Forums:
  IIS Doesn`t Like My Access Database  rebelfox at 16:20 on Monday, October 06, 2003
 

I have a small access database sitting on an XP machine with IIS 5.1. A set of my ASP pages read and update the database. For some reason I cannot access the data files. This was working fine for months until today when my machine crashed and I ended up installing IIS.

Now I when I navigate to my asp pages to view/update the access database I get the error:-

Error Type:
Microsoft JET Database Engine (0x80004005)

The Microsoft Jet database engine cannot open the
file 'C:\Inetpub\wwwroot\Phones\Phones.mdb'. It is
already opened exclusively by another user, or you need
permission to view its data.

There is nobody else using the database so it must be a permissions thing.

I have right clicked on the folder holding the database in file manager but can see nothing in the properties that allows the user permissions you get with Windows 2000 server ( 'browsers', authors' etc).

I have looked at the folder properties in IIS and found the 'Home Directory' tab allows read and write. The 'Directory Security tab' has no certificates but does
have 'Anonymous Access' ticked behind'Anonymous Access and Authentication Control' with a username of 'IUSR_' followed by the machine name.

The access database has no users set up in it.

Can somebody please help as this is driving me up the wall...onto the roof and jumping up and down on the guttering hoping it will give way :o(.


  Re: IIS Doesn`t Like My Access Database  Jeff Anderson at 08:55 on Tuesday, October 07, 2003
 

Hi
The answer I believe is in the right click on the actual database file itself. There should be a 'security tab - you need to give IUSR_MACHINENAME account write permission on the file. Also make sure the read only tick box is not checked, that can sometimes happen when you upload the database from somewhere else.
Hope that helps
Jeff

  Re: IIS Doesn`t Like My Access Database  rebelfox at 09:10 on Tuesday, October 07, 2003
 

Hmmmmm not the case with XP Professional.

The Read Only tick box is there and is unticked but the
security tab is not present. Have you seen the security tab against an object on an XP machione? If you have it would suggest my setup is peculiar.


  Re: IIS Doesn`t Like My Access Database  Jeff Anderson at 09:19 on Tuesday, October 07, 2003
 

Hi
If the security tab is not showing, go to the Explorer Tools/Folder Options/View, scroll down to the bottom of Advanced settings and uncheck "Use simple file sharing". That should make the security settings appear.
THanks
Jeff


  Re: IIS Doesn`t Like My Access Database  rebelfox at 09:35 on Tuesday, October 07, 2003
 

Thankyou so much!

I have been stuck on this problem for two days and now I feel a bit of a dimwit for not knowing this.

Many, many thanks.

  Re: IIS Doesn`t Like My Access Database  Jeff Anderson at 09:36 on Tuesday, October 07, 2003
 

Hey - you're welcome!








CodeToad Experts

Can't find the answer?
Our Site experts are answering questions for free in the CodeToad forums








Recent Forum Threads
• SoftIce Driver Suite 3.0.1
• metrowerks codewarrior 9.0
• Mapinfo.Professional.v7.0
• GardenGraphics DynaSCAPE Professional 3.02
• Embroidery Great Notions 2004 part01-74
• EFI_BEST_COLORPROOF_V5.0
• AViD.SOFTiMAGE.XSi.V4.2.CD1-NNiSO
• AUTOFX.PHOTOGRAPHIC.EDGES.6.0.CD1
• 0 STI.SASSPro.v2.0.0.2 working full


Recent Articles
ASP GetTempName
Decode and Encode UTF-8
ASP GetFile
ASP FolderExists
ASP FileExists
ASP OpenTextFile
ASP FilesystemObject
ASP CreateFolder
ASP CreateTextFile
Javascript Get Selected Text


© Copyright codetoad.com 2001-2014